来自当知百科
跳转到: 导航搜索
  
路由器

目录

基本概念

  所谓路由就是指通过相互连接的网络把信息从源地点移动到目标地点的活动。一般来说,在路由过程中,信息至少会经过一个或多个中间节点。通常,人们会把路由和交换进行对比,这主要是因为在普通用户看来两者所实现的功能是完全一样的。其实,路由和交换之间的主要区别就是交换发生在OSI参考模型的第二层(数据链路层),而路由发生在第三层,即网络层。这一区别决定了路由和交换在移动信息的过程中需要使用不同的控制信息,所以两者实现各自功能的方式是不同的。

  早在40多年前间就已经出现了对路由技术的讨论,但是直到80年代路由技术才逐渐进入商业化的应用。路由技术之所以在问世之初没有被广泛使用主要是因为80年代之前的网络结构都非常简单,路由技术没有用武之地。直到最近十几年,大规模的互联网络才逐渐流行起来,为路由技术的发展提供了良好的基础和平台。

  路由器是互联网的主要节点设备。路由器通过路由决定数据的转发。转发策略称为路由选择(routing),这也是路由器名称的由来(router,转发者)。作为不同网络之间互相连接的枢纽,路由器系统构成了基于TCP/IP 的国际互联网络 Internet 的主体脉络,也可以说,路由器构成了 Internet的骨架。它的处理速度是网络通信的主要瓶颈之一,它的可靠性则直接影响着网络互连的质量。因此,在园区网、地区网、乃至整个 Internet 研究领域中,路由器技术始终处于核心地位,其发展历程和方向,成为整个Internet研究的一个缩影。在当前我国网络基础建设和信息建设方兴未艾之际,探讨路由器在互连网络中的作用、地位及其发展方向,对于国内的网络技术研究、网络建设,以及明确网络市场上对于路由器和网络互连的各种似是而非的概念,都有重要的意义。

原理

  路由器(Router)是用于连接多个逻辑上分开的网络,所谓逻辑网络是代表一个单独的网络或者一个子网。当数据从一个子网传输到另一个子网时,可通过路由器来完成。因此,路由器具有判断网络地址和选择路径的功能,它能在多网络互联环境中,建立灵活的连接,可用完全不同的数据分组和介质访问方法连接各种子网,路由器只接受源站或其他路由器的信息,属网络层的一种互联设备。它不关心各子网使用的硬件设备,但要求运行与网络层协议相一致的软件。路由器分本地路由器和远程路由器,本地路由器是用来连接网络传输介质的,如光纤、同轴电缆、双绞线;远程路由器是用来连接远程传输介质,并要求相应的设备,如电话线要配调制解调器,无线要通过无线接收机、发射机。
路由器原理

  其工作原理如下: 

  (1)工作站A将工作站B的地址12.0.0.5连同数据信息以数据帧的形式发送给路由器1。 

  (2)路由器1收到工作站A的数据帧后,先从报头中取出地址12.0.0.5,并根据路径表计算出发往工作站B的最佳路径:R1->R2->R5->B;并将数据帧发往路由器2。 

  (3)路由器2重复路由器1的工作,并将数据帧转发给路由器5。 

  (4)路由器5同样取出目的地址,发现12.0.0.5就在该路由器所连接的网段上,于是将该数据帧直接交给工作站B。 

  (5)工作站B收到工作站A的数据帧,一次通信过程宣告结束。

  事实上,路由器除了上述的路由选择这一主要功能外,还具有网络流量控制功能。有的路由器仅支持单一协议,但大部分路由器可以支持多种协议的传输,即多协议路由器。由于每一种协议都有自己的规则,要在一个路由器中完成多种协议的算法,势必会降低路由器的性能。因此,我们以为,支持多协议的路由器性能相对较低。用户购买路由器时,需要根据自己的实际情况,选择自己需要的网络协议的路由器。

  近年来出现了交换路由器产品,从本质上来说它不是什么新技术,而是为了提高通信能力,把交换机的原理组合到路由器中,使数据传输能力更快、更好。

作用

  路由器的一个作用是连通不同的网络,另一个作用是选择信息传送的线路。选择通畅快捷的近路,能大大提高通信速度,减轻网络系统通信负荷,节约网络系统资源,提高网络系统畅通率,从而让网络系统发挥出更大的效益来。

  从过滤网络流量的角度来看,路由器的作用与交换机和网桥非常相似。但是与工作在网络物理层,从物理上划分网段的交换机不同,路由器使用专门的软件协议从逻辑上对整个网络进行划分。例如,一台支持IP协议的路由器可以把网络划分成多个子网段,只有指向特殊IP地址的网络流量才可以通过路由器。对于每一个接收到的数据包,路由器都会重新计算其校验值,并写入新的物理地址。因此,使用路由器转发和过滤数据的速度往往要比只查看数据包物理地址的交换机慢。但是,对于那些结构复杂的网络,使用路由器可以提高网络的整体效率。路由器的另外一个明显优势就是可以自动过滤网络广播。从总体上说,在网络中添加路由器的整个安装过程要比即插即用的交换机复杂很多。

  一般说来,异种网络互联与多个子网互联都应采用路由器来完成。

  路由器的主要工作就是为经过路由器的每个数据帧寻找一条最佳传输路径,并将该数据有效地传送到目的站点。由此可见,选择最佳路径的策略即路由算法是路由器的关键所在。为了完成这项工作,在路由器中保存着各种传输路径的相关数据--路径表(RoutingTable),供路由选择时使用。路径表中保存着子网的标志信息、网上路由器的个数和下一个路由器的名字等内容。路径表可以是由系统管理员固定设置好的,也可以由系统动态修改,可以由路由器自动调整,也可以由主机控制。

  1.静态路径表

  由系统管理员事先设置好固定的路径表称之为静态(static)路径表,一般是在系统安装时就根据网络的配置情况预先设定的,它不会随未来网络结构的改变而改变。

  2.动态路径表

  动态(Dynamic)路径表是路由器根据网络系统的运行情况而自动调整的路径表。路由器根据路由选择协议(RoutingProtocol)提供的功能,自动学习和记忆网络运行情况,在需要时自动计算数据传输的最佳路径。

使用级别分类

  互联网各种级别的网络中随处都可见到路由器。接入网络使得家庭和小型企业可以连接到某个互联网服务提供商;企业网中的路由器连接一个校园或企业内成千上万的计算机;骨干网上的路由器终端系统通常是不能直接访问的,它们连接长距离骨干网上的ISP和企业网络。互联网的快速发展无论是对骨干网、企业网还是接入网都带来了不同的挑战。骨干网要求路由器能对少数链路进行高速路由转发。企业级路由器不但要求端口数目多、价格低廉,而且要求配置起来简单方便,并提供QoS。

1.接入路由器

  接入路由器连接家庭或ISP内的小型企业客户。接入路由器已经开始不只是提供SLIP或PPP连接,还支持诸如PPTP和IPSec等虚拟私有网络协议。这些协议要能在每个端口上运行。诸如ADSL等技术将很快提高各家庭的可用带宽,这将进一步增加接入路由器的负担。由于这些趋势,接入路由器将来会支持许多异构和高速端口,并在各个端口能够运行多种协议,同时还要避开电话交换网。

2.企业级路由器

  企业或校园级路由器连接许多终端系统,其主要目标是以尽量便宜的方法实现尽可能多的端点互连,并且进一步要求支持不同的服务质量。许多现有的企业网络都是由Hub或网桥连接起来的以太网段。尽管这些设备价格便宜、易于安装、无需配置,但是它们不支持服务等级。相反,有路由器参与的网络能够将机器分成多个碰撞域,并因此能够控制一个网络的大小。此外,路由器还支持一定的服务等级,至少允许分成多个优先级别。但是路由器的每端口造价要贵些,并且在能够使用之前要进行大量的配置工作。因此,企业路由器的成败就在于是否提供大量端口且每端口的造价很低,是否容易配置,是否支持QoS。另外还要求企业级路由器有效地支持广播和组播。企业网络还要处理历史遗留的各种LAN技术,支持多种协议,包括IP、IPX和Vine。它们还要支持防火墙、包过滤以及大量的管理和安全策略以及VLAN。

3.骨干级路由器

  骨干级路由器实现企业级网络的互联。对它的要求是速度和可靠性,而代价则处于次要地位。硬件可靠性可以采用电话交换网中使用的技术,如热备份、双电源、双数据通路等来获得。这些技术对所有骨干路由器而言差不多是标准的。骨干IP路由器的主要性能瓶颈是在转发表中查找某个路由所耗的时间。当收到一个包时,输入端口在转发表中查找该包的目的地址以确定其目的端口,当包越短或者当包要发往许多目的端口时,势必增加路由查找的代价。因此,将一些常访问的目的端口放到缓存中能够提高路由查找的效率。不管是输入缓冲还是输出缓冲路由器,都存在路由查找的瓶颈问题。除了性能瓶颈问题,路由器的稳定性也是一个常被忽视的问题。

4.太比特路由器

  在未来核心互联网使用的三种主要技术中,光纤和DWDM都已经是很成熟的并且是现成的。如果没有与现有的光纤技术和DWDM技术提供的原始带宽对应的路由器,新的网络基础设施将无法从根本上得到性能的改善,因此开发高性能的骨干交换/路由器(太比特路由器)已经成为一项迫切的要求。太比特路由器技术现在还主要处于开发实验阶段。

5. 多WAN路由器

  早在2000年,北京欣全向工程师在研究一种多链路(Multi-Homing)解决方案时发现,全部以太网协议的多WAN口设备在中国存在巨大的市场需求。伴随着欣全向产品研发成功,全国第一台双WAN路由器诞生于公元2002年,中国第一款双WAN宽带路由器被命名为NuR8021。

  双WAN路由器具有物理上的2个WAN口作为外网接入,这样内网电脑就可以经过双WAN路由器的负载均衡功能同时使用2条外网接入线路,大幅提高了网络带宽。当前双WAN路由器主要有“带宽汇聚”和“一网双线”的应用优势,这是传统单WAN路由器做不到的。

功能级别分类

宽带路由器

  宽带路由器是近几年来新兴的一种网络产品,它伴随着宽带的普及应运而生。宽带路由器在一个紧凑的箱子中集成了路由器、防火墙、带宽控制和管理等功能,具备快速转发能力,灵活的网络管理和丰富的网络状态等特点。多数宽带路由器针对中国宽带应用优化设计,可满足不同的网络流量环境,具备满足良好的电网适应性和网络兼容性。多数宽带路由器采用高度集成设计,集成10/100Mbps宽带以太网WAN接口、并内置多口10/100Mbps自适应交换机,方便多台机器连接内部网络与Internet,可以广泛应用于家庭、学校、办公室、网吧、小区接入、政府、企业等场合。

模块化路由器

  模块化路由器主要是指该路由器的接口类型及部分扩展功能是可以根据用户的实际需求来配置的路由器,这些路由器在出厂时一般只提供最基本的路由功能,用户可以根据所要连接的网络类型来选择相应的模块,不同的模块可以提供不同的连接和管理功能。例如,绝大多数模块化路由器可以允许用户选择网络接口类型,有些模块化路由器可以提供VPN等功能模块,有些模块化路由器还提供防火墙的功能,等等。目前的多数路由器都是模块化路由器。

非模块化路由器

  非模块化路由器都是低端路由器,平时家用的即为这类非模块化路由器。该类路由器主要用于连接家庭或ISP内的小型企业客户。它不仅提供SLIP或PPP连接,还支持诸如PPTP和IPSec等虚拟私有网络协议。这些协议要能在每个端口上运行。诸如ADSL等技术将很快提高各家庭的可用宽带,这将进一步增加接入路由器的负担。由于这些趋势,该类路由器将来会支持许多异构和高速端口,并在各个端口能够运行多种协议,同时还要避开电话交换网

虚拟路由器

  虚拟路由器以虚求实最近,一些有关IP骨干网络设备的新技术突破,为将来因特网新服务的实现铺平了道路。虚拟路由器就是这样一种新技术,它使一些新型因特网服务成为可能。通过这些新型服务,用户将可以对网络的性能、因特网地址和路由以及网络安全等进行控制。以色列RND网络公司是一家提供从局域网到广域网解决方案的厂商,该公司最早提出了虚拟路由的概念。

核心路由器

  核心路由器又称“骨干路由器”,是位于网络中心的路由器。位于网络边缘的路由器叫接入路由器。核心路由器和边缘路由器是相对概念。它们都属于路由器,但是有不同的大小和容量。某一层的核心路由器是另一层的边缘路由器。

无线路由器

  无线路由器就是带有无线覆盖功能的路由器,它主要应用于用户上网和无线覆盖。市场上流行的无线路由器一般都支持专线xdsl/cable,动态xdsl,pptp四种接入方式,它还具有其它一些网络管理的功能,如dhcp服务、nat防火墙、mac地址过滤等等功能。

独臂路由器

  独臂路由器的概念是出现在三层交换机之前,网内各个VLAN之间的通信可以用ISL关联来实现,那样的话,路由器就成为一个“独臂路由器”,VLAN之间的数据传输要进入先路由器处理,然后输出,以使得网络中的大部分报文同一个VLAN内的报文将用不着通过路由器而直接在交换设备间进行高速传输。这种路由方式的不足之处在于它仍然是一种集中式的路由策略,因此在主干网上一般均设置有多个冗余“独臂”路由器,来分担数据处理任务,从而可以减少因路由器引起的瓶颈问题,还可以增加冗余链路,但如果网络中VLAN之间的数据传输量比较大,那么在路由器处将形成瓶颈。独臂路由器现在基本被第3层交换机取代

无线网络路由器

  无线网络路由器是一种用来连接有线和无线网络的通讯设备,它可以通过Wi-Fi技术收发无线信号来与个人数码助理和笔记本等设备通讯。无线网络路由器可以在不设电缆的情况下,方便地建立一个电脑网络。

  但是,在户外通过无线网络进行数据传输时,它的速度可能会受到天气的影响。其他的无线网络还包括了红外线、蓝牙及卫星微波等。

智能流控路由器

  智能流控路由器能够在自动地调整每个节点的带宽,这样每个节点的网速均能达到最快,不用限制每个节点的速度,这是其最大的特点.智能流控路由器经常用在电信的主干道上,如华为,思科。网吧,酒店等则常用网星路由器。

动态限速路由器

  动态限速路由器是一种能实时地计算每位用户所需要的带宽,精确分析用户上网类型,并合理分配带宽,达到按需分配,合理利用,还具有优先通道的智能调配功能,这种功能主要应用于网吧、酒店、小区、学校等,网吧最长用的则是奥雷路由器。

体系构成

  从体系结构上看,路由器可以分为第一代单总线单CPU结构路由器、第二代单总线主从CPU结构路由器、第三代单总线对称式多CPU结构路由器;第四代多总线多CPU结构路由器、第五代共享内存式结构路由器、第六代交叉开关体系结构路由器和基于机群系统的路由器等多类。

  路由器具有四个要素:输入端口、输出端口、交换开关、路由处理器和其他端口

  输入端口是物理链路和输入包的进口处。端口通常由线卡提供,一块线卡一般支持4、8或16个端口,一个输入端口具有许多功能。第一个功能是进行数据链路层的封装和解封装。第二个功能是在转发表中查找输入包目的地址从而决定目的端口(称为路由查找),路由查找可以使用一般的硬件来实现,或者通过在每块线卡上嵌入一个微处理器来完成。第三,为了提供QoS(服务质量),端口要对收到的包分成几个预定义的服务级别。第四,端口可能需要运行诸如SLIP(串行线网际协议)和PPP(点对点协议)这样的数据链路级协议或者诸如PPTP(点对点隧道协议)这样的网络级协议。一旦路由查找完成,必须用交换开关将包送到其输出端口。如果路由器是输入端加队列的,则有几个输入端共享同一个交换开关。这样输入端口的最后一项功能是参加对公共资源(如交换开关)的仲裁协议。

  交换开关可以使用多种不同的技术来实现。迄今为止使用最多的交换开关技术是总线、交叉开关和共享存贮器。最简单的开关使用一条总线来连接所有输入和输出端口,总线开关的缺点是其交换容量受限于总线的容量以及为共享总线仲裁所带来的额外开销。交叉开关通过开关提供多条数据通路,具有N×N个交叉点的交叉开关可以被认为具有2N条总线。如果一个交叉是闭合,输入总线上的数据在输出总线上可用,否则不可用。交叉点的闭合与打开由调度器来控制,因此,调度器限制了交换开关的速度。在共享存贮器路由器中,进来的包被存贮在共享存贮器中,所交换的仅是包的指针,这提高了交换容量,但是,开关的速度受限于存贮器的存取速度。尽管存贮器容量每18个月能够翻一番,但存贮器的存取时间每年仅降低5%,这是共享存贮器交换开关的一个固有限制。

  输出端口在包被发送到输出链路之前对包存贮,可以实现复杂的调度算法以支持优先级等要求。与输入端口一样,输出端口同样要能支持数据链路层的封装和解封装,以及许多较高级协议。

  路由处理器计算转发表实现路由协议,并运行对路由器进行配置和管理的软件。同时,它还处理那些目的地址不在线卡转发表中的包。

  其他端口一般指控制端口,由于路由器本身不带有输入和终端显示设备,但它需要进行必要的配置后才能正常使用,所以一般的路由器都带有一个控制端口"Console",用来与计算机或终端设备进行连接,通过特定的软件来进行路由器的配置。所有路由器都安装了控制台端口,使用户或管理员能够利用终端与路由器进行通信,完成路由器配置。该端口提供了一个EIA/TIA-232异步串行接口,用于在本地对路由器进行配置(首次配置必须通过控制台端口进行)。

  Console端口使用配置专用连线直接连接至计算机串口,利用终端仿真程序(如Windows下的"超级终端")进行路由器本地配置。路由器的Console端口多为RJ-45端口。如下图就包含了一个Console配置端口。

配置与调试

  路由器在计算机网络中有着举足轻重的地位,是计算机网络的桥梁。通过它不仅可以连通不同的网络,还能选择数据传送的路径,并能阻隔非法的访问。

  路由器的配置对初学者来说,并不是件十分容易的事。现将路由器的一般配置和简单调试介绍给大家,供朋友们在配置路由器时参考,本文以Cisco2501为例。

  Cisco2501有一个以太网口(AUI)、一个Console口(RJ45)、一个AUX口(RJ45)和两个同步串口,支持DTE和DCE设备,支持 EIA/TIA-232、 EIA/TIA-449、 V.35、X.25和EIA-530接口。

配置

  1.配置以太网端口

  # conf t(从终端配置路由器)

  # int e0(指定E0口)

  # ip addr ABCD XXXX(ABCD 为以太网地址,XXXX为子网掩码

  # ip addr ABCD XXXX secondary(E0口同时支持两个地址类型。如果第一个为A类地址,则第二个为B或C类地址)

  # no shutdown(激活E0口)

  # exit

  完成以上配置后,用ping命令检查E0口是否正常。如果不正常,一般是因为没有激活该端口,初学者往往容易忽视。用noshutdown命令激活E0口即可。

  2.X.25的配置

  # conf t

  # int S0(指定S0口)

  # ip addr ABCD XXXX(ABCD 为以太网S0 的IP地址,XXXX为子网掩码)

  # encap X25-ABC(封装X.25协议。ABC指定X.25为DTE或DCE操作,缺省为DTE)

  # x25 addr ABCD(ABCD为S0的X.25端口地址,由邮电局提供)

  # x25 map ip ABCD XXXX br(映射的X.25地址。ABCD为对方路由器(如:S0)的IP地址,XXXX为对方路由器(如:S0)的X.25端口地址)

  # x25 htc X(配置最高双向通道数。X的取值范围1-4095,要根据 邮电局实际提供的数字配置)

  # x25 nvc X(配置虚电路数,X不可超过邮电局实际提供的数否则将影响数据的正常传输)

  # exit

  S0端口配置完成后,用no shutdown命令激活E0口。如果ping S0端口正常,ping 映射的X.25IP地址即对方路由器端口IP地址不通,则可能是以下几种情况引起的:1)本机X.25地址配置错误,重新与邮局核对(X.25地址长度为13位);2)本机映射IP地址或X.25地址配置错误,重新配置正确;3)对方IP地址或X.25地址配置错误;4)本机或对方路由配置错误。

  能够与对方通讯,但有丢包现象。出现这种情况,一般有以下几种可能:1)线路情况不好,或网卡、RJ45插头接触不良;2)x25htc最高双向通道数X的取值范围和x25nvc虚电路数X超出邮电局实际提供的数字。最高双向通道数和虚电路数这两个值越大越好,但绝对不能超出邮电局实际提供的数字,否则就会出现丢包现象。

  3.专线的配置

  # conf t

  # int S2(指定S2口)

  # ip addr ABCD XXXX(ABCD 为S2 的IP地址,XXXX为子网掩码)

  # exit

  专线口配置完成后,用no shutdown命令激活S2口即可。

  4.帧中继的配置

  # conf t

  # int s0

  # ip addr ABCD XXXX (ABCD 为S0 的IP地址,XXXX为子网掩码)

  # encap frame_relay (封装frame_relay 协议)

  # no nrzi_encoding (NRZI=NO)

  # frame_relay lmi_type q933a (LMI使用Q933A标准.LMI(Local managementInterface) 有3种:ANSI:T1.617、CCITTY:Q933A和Cisco特有的标准)

  # frame-relayintf-typ ABC(ABC为帧中继设备类型,它们分别是DTE设备、DCE交换机或NNI(网络接点接口)支持)

  # frame_relay interface_dlci 110 br(配置DLCI(数据链路连接标识符))

  # frame-relay map ip ABCD XXXX broadcast(建立帧中继映射。ABCD为对方IP地址,XXXX为本地DLCI号,broadcast允许广播向前转发或更新路由)

  # no shutdown (激活本端口)

  # exit

  帧中继S0端口配置完成后,用ping命令检查S0口。如果不正常,通常是因为没有激活该端口,用noshutdown命令激活S0口即可。如果ping S0端口正常,ping映射的IP地址不正常,则可能是帧中继交换机或对方配置错误,需要综合排查。

  5.配置同步/异步口(适用于2522)

  # conf t

  # int s2

  # ph asyn (配置S2为异步口)

  # ph sync (配置S2为同步口)

  6.动态路由的配置

  # conf t

  # router eigrp 20 (使用EIGRP路由协议。常用的路由协议有RIP、IGRP、IS-IS等)

  # passive-interface serial0 (若S0与X.25相连,则输入本条指令)

  # passive-interface serial1 (若S1与X.25相连,则输入本条指令)

  # network ABCD (ABCD为本机的以太网地址)

  # network XXXX (XXXX为S0的IP地址)

  # no auto-summary

  # exit

  7.静态路由的配置

  # ip router ABCD XXXX YYYY 90 (ABCD为对方路由器的以太网地址,XXXX为子网掩码,YYYY为对方对应的广域网端口地址)

  # dialer-list 1 protocol ip permit

综合调试

  当路由器全部配置完毕后,可进行一次综合调试。

  1.首先将路由器的以太网口和所有要使用的串口都激活。方法是进入该口,执行no shutdown。

  2.将和路由器相连的主机加上缺省路由中心路由器的以太地址)。方法是在Unix系统的超级用户下执行:router adddefault XXXX 1(XXXX为路由器的E0口地址)。每台主机都要加缺省路由,否则,将不能正常通讯。

  3.ping本机的路由器以太网口,若不通,可能以太网口没有激活或不在一个网段上。ping广域网口,若不通,则没有加缺省路由。ping对方广域网口,若不通,路由器配置错误。ping主机以太网口,若不通,对方主机没有加缺省路由。

  4.在专线卡X.25主机上加网关(静态路由)。方法是在Unix系统的超级用户下执行:router add X.X.X.XY.Y.Y.Y 1(X.X.X.X为对方以太网地址,Y.Y.Y.Y为对方广域网地址)。

  5.使用Tracert对路由进行跟踪,以确定不通网段。

路由器的选购

  选择路由器时应注意安全性、控制软件、网络扩展能力、网管系统、带电插拔能力等方面。

  1.由于路由器是网络中比较关键的设备,针对网络存在的各种安全隐患,路由器必须具有如下的安全特性

  (1)可靠性与线路安全可靠性要求是针对故障恢复和负载能力而提出来的。对于路由器来说,可靠性主要体现在接口故障和网络流量增大两种情况下,为此,备份是路由器不可或缺的手段之一。当主接口出现故障时,备份接口自动投入工作,保证网络的正常运行。当网络流量增大时,备份接口又可承当负载分担的任务。 (2)身份认证路由器中的身份认证主要包括访问路由器时的身份认证、对端路由器的身份认证和路由信息的身份认证。

  (3)访问控制 对于路由器的访问控制,需要进行口令的分级保护。有基于IP地址的访问控制和基于用户的访问控制。

  (4)信息隐藏与对端通信时,不一定需要用真实身份进行通信。通过地址转换,可以做到隐藏网内地址,只以公共地址的方式访问外部网络。除了由内部网络首先发起的连接,网外用户不能通过地址转换直接访问网内资源。

  (5)数据加密

  (6)攻击探测和防范

  (7)安全管理

  2.路由器的控制软件是路由器发挥功能的一个关键环节。从软件的安装、参数自动设置,到软件版本的升级都是必不可少的。软件安装、参数设置及调试越方便,用户使用就越容易掌握,就能更好地应用。

  3.随着计算机网络应用的逐渐增加,现有的网络规模有可能不能满足实际需要,会产生扩大网络规模的要求,因此扩展能力是一个网络在设计和建设过程中必须要考虑的。扩展能力的大小主要看路由器支持的扩展槽数目或者扩展端口数目。

  4.随着网络的建设,网络规模会越来越大,网络的维护和管理就越难进行,所以网络管理显得尤为重要。5.在我们安装、调试、检修和维护或者扩展计算机网络的过程中,免不了要给网络中增减设备,也就是说可能会要插拔网络部件。那么路由器能否支持带电插拔,是路由器的一个重要的性能指标。

外型尺寸的选择

  如果网络已完成楼宇级的综合布线,工程要求网络设备上机式集中管理,应选择19英寸宽的机架式路由器,如Cisco2509、华为2501(配置同Cisco2501)。如果没有上述需求,桌面型的路由器如Intel的8100和Cisco的1600系列,具有更高的性能价格比。

协议的选择

  由于最初局域网并没先出标准后出产品,所以很多厂商如Apple和IBM都提出了自己的标准,产生了如AppleTalk和IBM协议,Novell公司的网络操作系统运行IPX/SPX协议,在连接这些异构网络时需要路由器对这些协议提供支持。Intel9100系列和9200系列的路由器可提供免费支持,3Com的系列路由产品也提供较广泛的协议支持。

  路由器作为网络设备中的“黑匣子”,工作在后台。用户选择路由器时,多从技术角度来考虑,如可延展性、路由协议互操作性、广域数据服务支持、内部ATM支持、SAN集成能力等。另外,选择路由器还应遵循如下基本原则:即标准化原则、技术简单性原则、环境适应性原则、可管理性原则和容错冗余性原则。对于高端路由器,更多的还应该考虑是否和如何适应骨干网对网络高可靠性、接口高扩展性以及路由查找和数据转发的高性能要求。高可靠性、高扩展性和高性能的“三高”特性是高端路由器区别于中、低端路由器的关键所在。

CISCO路由器初始配置简介

  很多初学路由器知识的网友对路由器的初始配置可能感到很陌生,本人在初学时也很困惑,因为一下出来很多提问不知如何是好,下面将最近刚调试的一台CISCO3640的初始配置整理出来与各位网友交流,如有疏漏之处,还请大家指正。

  1.用CISCO随机带CONSOLE线,一端连在CISCO路由器的CONSOLE口,一端连在计算机的COM口。

  2.打开电脑,启动超级终端.为您的连接取个名字,比如CISCO_SETUP,下一步选定连接时用COM1,下一步选定第秒位数9600,数据位8,奇偶校验无,停止位1,数据流控制无.最后选确定。

  3.打开路由器电源,这时超级终端将出现以下画面:

  System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASESOFTWARE (fc1)

  Copyright (c) 1999 by cisco Systems, Inc.C3600 processor with32768 Kbytes of main memory Main memory is configured to 64 bitmode with parity disabled

  program load complete, entry point: 0x80008000, size: 0x4ed478Self decompressing the image :

  ###################################################################

  ###################################################################

  ###################################################################

  ###################################################################

  ###################################################################

  ###################################################################

  ###################################################################

  [OK]

  Restricted Rights Legend

  Use, duplication, or disclosure by the Government is

  subject to restrictions as set forth in subparagraph

  (c) of the Commercial Computer Software - Restricted

  Rights clause at FAR sec. 52.227-19 and subparagraph

  (c) (1) (ii) of the Rights in Technical Data and Computer

  Software clause at DFARS sec. 252.227-7013.

  cisco Systems, Inc.

  170 West Tasman Drive

  San Jose, California 95134-1706

  Cisco Internetwork Operating System Software

  IOS (tm) 3600 Software (C3640-I-M), Version 12.1(2)T, RELEASESOFTWARE (fc1)

  Copyright (c) 1986-2000 by cisco Systems, Inc.

  Compiled Tue 16-May-00 12:26 by ccai

  Image text-base: 0x600088F0, data-base: 0x60924000

  cisco 3640 (R4700) processor (revision 0x00) with 24576K/8192Kbytes of memory.

  Processor board ID 25125768

  R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

  Bridging software.

  X.25 software, Version 3.0.0.

  2 FastEthernet/IEEE 802.3 interface(s)

  1 Serial network interface(s)

  DRAM configuration is 64 bits wide with parity disabled.

  125K bytes of non-volatile configuration memory.

  8192K bytes of processor board System flash (Read/Write)

  --- System Configuration Dialog ---

  Would you like to enter the initial configuration dialog?[yes/no]: y

  您是否进入初始化配置对话,选Y

  At any point you may enter a question mark '?' for help.

  Use ctrl-c to abort configuration dialog at any prompt.

  Default settings are in square brackets '[]'.Basic managementsetup configures only enough connectivity

  for management of the system, extended setup will ask you

  to configure each interface on the system

  Would you like to enter basic management setup? [yes/no]: n

  您是否进入基本配置安装,选N

  First, would you like to see the current interface summary?[yes]: y

  首先,您是否看一下当前端口状态

  Any interface listed with OK? value "NO" does not have a validconfiguration

  Interface IP-Address OK? Method Status Protocol

  FastEthernet0/0unassigned NO unset up down

  Serial0/0 unassigned NO unset down down

  FastEthernet0/1unassigned NO unset up down

  Configuring global parameters:

  Enter host name [Router]:RouterA

  输入路由器的名字

  The enable secret is a password used to protect access to

  privileged EXEC and configuration modes. This password, after

  entered, becomes encrypted in the configuration.

  Enter enable secret: aaa

  输入密文

  The enable password is used when you do not specify an

  enable secret password, with some older software versions, and

  some boot images.

  Enter enable password: bbb

  输入密码(不能和密文相同)

  The virtual terminal password is used to protect

  access to the router over a network interface.

  Enter virtual terminal password: ccc

  输入虚拟终端的密码(以备远程登录)

  Configure SNMP Network Management? [yes]: n

  配置简单网管吗?选N

  Configure IP? [yes]: y

  配置IP吗?选Y

  Configure IGRP routing? [yes]: n

  配置IGRP路由选择协议吗?选N

  Configure RIP routing? [no]:

  配置RIP路由选择协议吗?选N

  Configure bridging? [no]:

  配置桥接吗?选N

  Async lines accept incoming modems calls. If you will have

  users dialing in via modems, configure these lines.

  Configure Async lines? [yes]: n

  配置异步线路吗?选N

  Configuring interface parameters:

  Do you want to configure FastEthernet0/0 interface? [yes]: y

  您是否想配置fastethernet0/0接口?选Y

  Use the 100 Base-TX (RJ-45) connector? [yes]: y

  用RJ45的连接器吗?选Y

  Operate in full-duplex mode? [no]: y

  选用全双工模式?选Y

  Configure IP on this interface? [yes]: y

  在这个接口上配置IP吗?选Y

  IP address for this interface: 192.168.0.1

  配置该接口的IP地址(在此地址为192.168.0.1

  Subnet mask for this interface [255.255.255.0] :

  配置该接口的子网掩码.(默认的是255.255.255.0,可以手工输入修改)

  Class C network is 192.168.0.0, 24 subnet bits; mask is /24

  Do you want to configure Serial0/0 interface? [yes]: y

  您想配置serial0/0接口吗?选Y

  Some supported encapsulations are

  ppp/hdlc/frame-relay/lapb/x25/atm-dxi/smds

  Choose encapsulation type [hdlc]:

  选择封装方式(默认的封装方式是HDLC,您可根据与您的路由器相连选用的封装类型来决定用什么样的封装类型

  No serial cable seen.

  Choose mode from (dce/dte) [dte]:

  (因为没有连串口线所以会让您选择设备类型)

  Configure IP on this interface? [yes]: y

  (在接口上配置IP)

  Configure IP unnumbered on this interface? [no]:

  IP address for this interface: 172.16.0.5

  配置该接口的IP地址(在此地址为172.16.0.5)

  Subnet mask for this interface [255.255.0.0] : 255.255.255.252

  配置该接口的子网掩码.(默认的是255.255.0.0,可以手工输入修改为255.255.255.252)

  Class B network is 172.16.0.0, 30 subnet bits; mask is /30

  (以下配置同上)

  Do you want to configure FastEthernet0/1 interface? [yes]:

  Use the 100 Base-TX (RJ-45) connector? [yes]:

  Operate in full-duplex mode? [no]: y

  Configure IP on this interface? [yes]: y

  IP address for this interface: 172.16.0.9

  Subnet mask for this interface [255.255.0.0] : 255.255.255.252Class B network is 172.16.0.0, 30 subnet bits; mask is /30

  The following configuration command script was created:

  (把您的配置显示出来)

  hostname aaa

  enable secret 5 $ul/V$ezbZFgvzGHD.YPSieC0Ew/

  enable password RouterA

  line vty 0 4

  password ccc

  no snmp-server

  !

  ip routing

  no bridge 1

  !

  interface FastEthernet0/0

  media-type 100BaseX

  full-duplex

  ip address 192.168.0.1 255.255.255.0

  !

  interface Serial0/0

  encapsulation hdlc

  ip address 172.16.0.5 255.255.255.252

  !

  interface FastEthernet0/1

  media-type 100BaseX

  full-duplex

  ip address 172.16.0.9 255.255.255.252

  dialer-list 1 protocol ip permit

  dialer-list 1 protocol ipx permit

  !

  end

  以下提示您是否保存这次设置

  [0] Go to the IOS command prompt without saving this config.

  [1] Return back to the setup without saving this config.

  [2] Save this configuration to nvram and exit.

  Enter your selection [2]: 2

  选择2保存设置并存入NVRAM中

  Building configuration...

  [OK] Use the enabled mode 'configure' command to modify thisconfiguration.

  Press RETURN to get started!

  路由器重新启动

  00:00:08: %LINK-3-UPDOWN: Interface Serial0/0, changed state todown

  00:00:08: %LINK-3-UPDOWN: Interface FastEthernet0/0, changedstate to up

  00:00:08: %LINK-3-UPDOWN: Interface FastEthernet0/1, changedstate to up

  00:00:09: %LINEPROTO-5-UPDOWN: Line protocol on InterfaceSerial0/0, changed state to down

  00:00:09: %LINEPROTO-5-UPDOWN: Line protocol on InterfaceFastEthernet0/0, changed state to down

  00:00:09: %LINEPROTO-5-UPDOWN: Line protocol on InterfaceFastEthernet0/1, changed state to down

  00:03:18: %IP-5-WEBINST_KILL: Terminating DNS process

  00:03:24: %SYS-5-RESTART: System restarted --

  Cisco Internetwork Operating System Software

  IOS (tm) 3600 Software (C3640-I-M), Version 12.1(2)T, RELEASESOFTWARE (fc1)

  Copyright (c) 1986-2000 by cisco Systems, Inc.

  Compiled Tue 16-May-00 12:26 by ccai

  RouterA>

  进入用户模式

  RouterA>en

  Password:

  RouterA#

  进入全局模式

  RouterA#sh run

  查看现在运行的配置

  Building configuration...

  Current configuration:

  !

  version 12.1

  service timestamps debug uptime

  service timestamps log uptime

  no service password-encryption

  !

  hostname RouterA

  !

  enable secret 5 $ul/V$ezbZFgvzGHD.YPSieC0Ew/

  enable password bbb

  !

  memory-size iomem 25

  ip subnet-zero

  !

  interface FastEthernet0/0

  ip address 192.168.0.1 255.255.255.0

  speed auto

  full-duplex

  !

  interface Serial0/0

  ip address 172.16.0.5 255.255.255.252

  clockrate 2000000

  !

  interface FastEthernet0/1

  ip address 172.16.0.9 255.255.255.252

  speed auto

  full-duplex

  !

  ip classless

  no ip http server

  !

  dialer-list 1 protocol ip permit

  dialer-list 1 protocol ipx permit

  !

  line con 0

  transport input none

  line aux 0

  line vty 0 4

  password ccc

  login

  !

  end

  现在您就完成了了一个新路由器的基本配置,接下来就可以进行进一步的详细配置了

相关概念辨析

低端和高端路由器的区别

  “低端路由器和高端路由器都是差不多的用法,为什么价格会相差这么远啊?”其实这个问题提得很不错,不少不熟悉产品技术的朋友基本上都会类似的疑问——“为什么一样的功能,这款路由器这么贵,另外一款又这么便宜”、“为什么思科的路由器这么贵?而TP-LINK的这么便宜?”、“这两款路由器的主要参数都一样,为什么性能却相差这么远?”

  对于这些问题,我们都必须从路由器的基本原理谈起。

  路由器的工作原理在上文已经介绍。

  把网络分段可以解决这些问题,但同时你必须提供一种机制使不同网段的计算机可以互相通信,就是促生了路由器这种设备:

  路由器工作在IP协议网络层,用于实现子网之间转发数据。路由器一般都有多个网络接口,包括局域的网络接口和广域的网络接口。每个网络接口连接不同的网络,路由器中记录有每个网络端口相连的网络信息。同时路由器中还保存有一张路由表,它记录有去往不同网络地址应送往的端口号。Internet用户使用的各种信息服务,其通讯的信息最终均可以归结为以IP包为单位的信息传送,IP包除了包括要传送的数据信息外,还包含有信息要发送到的目的IP地址、信息发送的源IP地址、以及一些相关的控制信息。当一台路由器收到一个IP数据包时,它将根据数据包中的目的IP地址项查找路由表,根据查找的结果将此IP数据包送往对应端口。下一台IP路由器收到此数据包后继续转发,直至发到目的地。路由器之间可以通过路由协议来进行路由信息的交换,从而更新路由表。

   影响路由器性能的因素

   经过上面的介绍,也许大家还是不怎么了解路由器的工作情况,其实没关系,这个也不是我们的目的,我们主要还是为了跟大家说明,路由器的工作原理决定了它必须使用芯片来完成一些必要的判断和数据包的转发,而这个工作是交由一个处理器来完成,各种有待处理或者处理好的数据包则存在内存里面,因此,处理器的工作频率和内存容量很大程度上决定着一款路由器的性能。

  但是,路由器的性能也不能完全看处理器频率和内存容量,处理器用得差路由器性能好不了,但反过来处理器好了路由器性能却不一定好;处理器主频只是处理器的一个性能指标,其总线宽度(16位还是32位)、Cache容量和结构、内部总线结构、是单CPU还是多CPU分布式处理、运算模式等指标,都会影响处理器性能。几乎所有路由器采用的都是通信专业RISCCPU,所以“采用通信专业RISCCPU”相当于什么都没说,关键要看这颗CPU到底用的是什么内核,内部结构如何。内存也是一样,内存容量大小并不决定一切,如果负载不大,那么4M的内存和8M的内存在使用时也许效果并不会有多大区别,所以根据内存的大小来绝对评判路由器性能并不科学(当然内存容量大还是有好处)。

  决定路由器档次的指标

  虽然上面已经说了,处理器和内存很大程度决定路由器性能,不过,决定一款路由器档次的指标却不是它们,这也是为什么在产品的主要参数中经常看不到有标出这两个参数,那么一般是用什么来衡量一个路由器的档次呢?一种说法就是负载能力,通俗一点也叫带机数量。不过,带机数量并不是一个标准化的数据量,它要根据实际的使用情况来衡量,例如网吧里所有人都在埋头上网聊天、游戏,而且几乎所有数据都通过路由器WAN口,所以负载很重;但如果是一个企业网,大部分人都在忙着搞设计、写报告、做计划,同一时间只有小部分人在用网络,而且大部分数据都是在企业网内部流动,所以路由器负载很轻,那就可以同时负载比较多的客户端。如果是说最大负载253台,那就没什么意义了,因为DHCP最大可以分配的IP地址数是254个,减掉路由器自己用掉的一个就是253个,这种不能称为指标,基本上是在唬人。所以,我们要看一款路由器的实际负载能力,而不是理论负载能力。

  由于负载能力存在诸多不确定因素和欺骗性质,所以,另外一个指标也颇受关注,那就是吞吐量。吞吐量是指路由器每秒能处理的数据量,这个参数是指LAN-to-WAN的吞吐量,其测量结果应是在NAT开启,防火墙关闭的情况下,分别用Smartbits和Chariot两种测试方式分别进行。用Smartbits方式时,比较64Byte小包测试数据,高下立判;Chariot测试最好是在多连接下进行,一般可以选择100对连接基本上就可以看出产品间的区别。

   影响路由器价格的原因

   经过上面的论述,最后终于可以回归到我们要回答的问题:为什么不同路由器之间价格区别这么大?

  主要原因:

  1.性能不同,性能强劲的路由器内置强悍的处理器和大容量内存,因此成本比较高。

  2.应用不同,性能强劲的路由器可以用于更多负载的网络,而低端路由器吃不消。

  3.功能不同,虽然基本功能一样,但是一些路由器还内置了其他比较实用的功能,像专业防火墙功能、VPN这些,因此技术要求较高,价格自然也会跟着提高。

路由器与交换机的区别

  传统交换机从网桥发展而来,属于OSI第二层即数据链路层设备。它根据MAC地址寻址,通过站表选择路由,站表的建立和维护由交换机自动进行。路由器属于OSI第三层即网络层设备,它根据IP地址进行寻址,通过路由表路由协议产生。交换机最大的好处是快速,由于交换机只须识别帧中MAC地址,直接根据MAC地址产生选择转发端口算法简单,便于ASIC实现,因此转发速度极高。但交换机的工作机制也带来一些问题。

  1.回路:根据交换机地址学习和站表建立算法,交换机之间不允许存在回路。一旦存在回路,必须启动生成树算法,阻塞掉产生回路的端口。而路由器的路由协议没有这个问题,路由器之间可以有多条通路来平衡负载,提高可靠性。

  2.负载集中:交换机之间只能有一条通路,使得信息集中在一条通信链路上,不能进行动态分配,以平衡负载。而路由器的路由协议算法可以避免这一点,OSPF路由协议算法不但能产生多条路由,而且能为不同的网络应用选择各自不同的最佳路由。

  3.广播控制:交换机只能缩小冲突域,而不能缩小广播域。整个交换式网络就是一个大的广播域,广播报文散到整个交换式网络。而路由器可以隔离广播域,广播报文不能通过路由器继续进行广播。

  4.子网划分:交换机只能识别MAC地址。MAC地址是物理地址,而且采用平坦的地址结构,因此不能根据MAC地址来划分子网。而路由器识别IP地址,IP地址由网络管理员分配,是逻辑地址且IP地址具有层次结构,被划分成网络号和主机号,可以非常方便地用于划分子网,路由器的主要功能就是用于连接不同的网络。

  5.保密问题:虽说交换机也可以根据帧的源MAC地址、目的MAC地址和其他帧中内容对帧实施过滤,但路由器根据报文的源IP地址、目的IP地址、TCP端口地址等内容对报文实施过滤,更加直观方便。

  6.介质相关:交换机作为桥接设备也能完成不同链路层和物理层之间的转换,但这种转换过程比较复杂,不适合ASIC实现,势必降低交换机的转发速度。因此目前交换机主要完成相同或相似物理介质和链路协议的网络互连,而不会用来在物理介质和链路层协议相差甚远的网络之间进行互连。而路由器则不同,它主要用于不同网络之间互连,因此能连接不同物理介质、链路层协议和网络层协议的网络。路由器在功能上虽然占据了优势,但价格昂贵,报文转发速度低。

无线路由器与无线AP的区别

  以功能区分无线AP与无线路由

  无线路由器:无线路由器是单纯型AP与宽带路由器的一种结合体;它借助于路由器功能,可实现家庭无线网络中的Internet连接共享,实现ADSL和小区宽带的无线共享接入,另外,无线路由器可以把通过它进行无线和有线连接的终端都分配到一个子网,这样子网内的各种设备交换数据就非常方便。

  可以这样说,无线路由器就是AP、路由功能和交换机的集合体,支持有线无线组成同一子网,直接接上MODEM。而无线AP相当于一个无线交换机,接在有线交换机或路由器上,为跟它连接的无线网卡从路由器那里分得IP。

  以应用区分无线AP与无线路由

  独立的AP在那些需要大量AP来进行大面积覆盖的公司使用得比较多,所有AP通过以太网连接起来并连到独立的无线局域网防火墙。

  无线路由器在SOHO的环境中使用得比较多,在这种环境下,一个AP就足够了。这样的话,整合了宽带接入路由器和AP的无线路由器就提供了单个机器的解决方案,它比起两个分开的机器的方案要容易管理和便宜一些。

  无线路由器一般包括了网络地址转换(NAT)协议,以支持无线局域网用户的网络连接共享--这是SOHO环境中很好用的一个功能。它们也可能有基本的防火墙或者信息包过滤器来防止端口扫描软件和其他针对宽带连接的攻击。最后,大多数无线路由器包括一个四个端口的以太网转换器,可以连接几台有线的PC。这对于管理路由器或者把一台打印机连上局域网来说非常方便。

  以组网拓扑图分析无线AP与无线路由

  AP不能直接跟ADSL MODEM相连,所以在使用时必须再添加一台交换机或者集线器;

  使用上面的拓扑架构时,AP和无线路由的用法是一样的。不过,大部分无线路由器由于具有宽带拨号的能力,因此可以直接跟ADSLMODEM连接进行宽带共享:

  以成本来分析无线AP与无线路由

  802.11B的无线AP和无线路由器的价钱相差不多,一般无线路由器会贵100元左右;802.11G则要看具体情况而言,根据品牌和附加功能的不同两者价格会有几百元不等的差距,不过便宜的产品差价也是100多元。

  无线路由器的标准

  美国电气和电子工程师协会(Institute of Electrical and ElectronicsEngineers,IEEE)于2009.9.14正式批准了最新的Wi-Fi无线标准802.11n。

  理论上讲,802.11n可以达到300Mbps的传输速率,这是802.11g标准的6倍,802.11b标准的30倍。

  施工、安装要点

  具体施工做法参见国家建筑标准设计图集《智能家居控制系统施工图集 03X602》及国际标准规范 《EIA/TIA569商务楼通信通道和空间标准》。

个人工具
名字空间

变换
查看
操作
导航
工具箱