来自当知百科
跳转到: 导航搜索

英文内容

  802.1Q

  An IEEE standard for providing VLAN identification and quality ofservice (QoS) levels. Four bytes are added to an Ethernet frame,increasing the maximum frame size from 1518 to 1522 bytes. Threebits are used to allow eight priority levels (QoS) and 12 bits areused to identify up to 4096 VLANs. 802.1q is the IEEE specificationfor implementation of VLANs (Virtual Local Area Networks) in Layer2 LAN switches, with emphasis on Ethernet. Similar to 802.1P,prioritization of traffic is accomplished through an additionalfour bytes of data in the frame header. Most data fields in thisaddition to the header are specific to VLAN operation. Alsoincluded is a field which provides the same 3-bit priority flagspecified in 802.1P's priority-mapping scheme. In addition toconventional data traffic, 802.1Q supports voice and videotransmission through Ethernet switches. In short, the 802.1Qspecification provides a 32-bit header for VLAN frame tagging. Each802.1Q tag sits in an Ethernet frame between the source addressfield and the media access control (MAC) client type/length field.An important feature of 802.1Q is the ability to share multiplesubnets across a high-speed link. This capability not only reducedthe number of lower speed links needed for physical separation, butit also allowed for asymmetrical traffic management so thatdifferent speed links could be managed more easily. With IEEE802.1p and 802.1Q, we saw the introduction of some importantconcepts that have been carried forward for further QoS (Quality ofService) development. These 802.1 features also can be mapped intohigher layer protocols like IP and ATM.

  An IEEE standard for providing VLAN identification and quality ofservice (QoS) levels. Four bytes are added to an Ethernet frame,increasing the maximum frame size from 1518 to 1522 bytes. Threebits are used to allow eight priority levels (QoS) and 12 bits areused to identify up to 4096 VLANs. 802.1q is the IEEE specificationfor implementation of VLANs (Virtual Local Area Networks) in Layer2 LAN switches, with emphasis on Ethernet. Similar to 802.1P,prioritization of traffic is accomplished through an additionalfour bytes of data in the frame header. Most data fields in thisaddition to the header are specific to VLAN operation. Alsoincluded is a field which provides the same 3-bit priority flagspecified in 802.1P's priority-mapping scheme. In addition toconventional data traffic, 802.1Q supports voice and videotransmission through Ethernet switches. In short, the 802.1Qspecification provides a 32-bit header for VLAN frame tagging. Each802.1Q tag sits in an Ethernet frame between the source addressfield and the media access control (MAC) client type/length field.An important feature of 802.1Q is the ability to share multiplesubnets across a high-speed link. This capability not only reducedthe number of lower speed links needed for physical separation, butit also allowed for asymmetrical traffic management so thatdifferent speed links could be managed more easily. With IEEE802.1p and 802.1Q, we saw the introduction of some importantconcepts that have been carried forward for further QoS (Quality ofService) development. These 802.1 features also can be mapped intohigher layer protocols like IP and ATM.

中文内容

  IEEE关于提供VLAN(虚拟局域网)识别和服务质量(QoS)等级的标准。在以太网一个帧当中加入4个字节,将一帧的最大长度从1518字节提高到1522字节。4个字节中的3比特提供8种优先等级,12比特用于最多识别4096种虚拟以太网。在第二层局域网交换,尤其是以太网中,802.1q成为IEEE虚拟以太网实施的技术规范。与802.1P相类似,通信业务优先权的确定是通过在帧标题中额外加入一个4字节数据来完成的。在帧标题中额外加入的大多数数据段仅限于虚拟以太网操作。帧标题中还包括一个数据段,提供802.1P优先权设定方案中给出的相同的3比特优先标记。除了一般的数据通信业务,802.1Q还通过以太网交换支持话音和视频传输。简而言之,802.1Q技术规范为虚拟以太网帧标签提供一个32位标题。每一个802.1Q标签位于以太网帧源地址字段和介质访问控制(MAC)客户类型/长度字段之间。802.1Q的一个重要特点是能够通过一个高速链路共享多重子网。这一功能不仅减少了物理分离所需的低速链路数量,而且还允许进行非对称通信业务管理,这样能够更容易对不同速度的链路进行管理。通过IEEE802.1p和802.1Q,我们可以看到一些已经为服务质量(QoS)进一步开发所采纳的重要理念。这些802.1特性还可以被引入更高一层的协议,如IP和ATM。

DOT1Q和 ISL的区别

  dot1q就是802.1q,是vlan的一种封装方式。dot就是点的意思,就简写为dot1q了.

  DOT1Q和ISL的区别:DOT1Q是各类产品的VLAN通用协议模式,Dot1q是一种普遍使用的标准,适用所有交换机与路由设备。ISL是CISCO设备的专用协议,适用于Cisco设备。 ISL(InteriorSwitchingLink)交换机间协议用于实现CISCO交换机间的VLAN中继。它是一个信息包标记协议,在支持ISL接口上发送的帧由一个标准以太网帧及相关的VLAN信息组成。

  R2(config)#interface fastethernet 0/0.1

  R2(config-subif)#encapsulation dot1qvlan100/封装802.1q协议,并把该端口划分到vlan100

  g-subif)#ip address 202.114.12.1 255.255.255.192

  R2(config-subif)#no shutdown

  R2(config-subif)#exit

  R2(config)#interface fastethernet 0/0.2

  R2(config-subif)#encapsulation dot1q vlan200

  R2(config-subif)#ip address 202.114.12.65 255.255.255.192

  R2(config-subif)#no shutdown

  R2(config-subif)#exit

  R2(config)#interface fastethernet 0/0.3

  R2(config-subif)#encapsulation dot1q vlan300

  R2(config-subif)#ip address 202.114.12.129 255.255.255.192

  R2(config-subif)#no shutdown

  R2(config-subif)#exit

  R2(config)#interface fastether0/0

  R2(config-if)#no shutdown

  Switch0(config)#interface f0/24

  Switch0(config-if)# switchport mode trunk

  Switch0 (config-if)#switchport trunk encapsulation dot1q

  Switch0(config-if)# switchport trunk allowed all

  Switch0(config-if)#exit

个人工具
名字空间

变换
查看
操作
导航
工具箱